$re = '/(?<name>\w+)\s*(\((?<e>([^()]*+|(?2))+)\))/mx';
$str = 'foo(() ((hello) world))
bar (hello world!)
baz((()))
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);