# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/[A-Z.,]*//gi;t' <<< "The/DT suburb/NN of/IN Saffron/NNP Park/NNP lay/VBD on/IN the/DT sunset/JJ side/NN of/IN London/NNP ,/, as/IN red/JJ and/CC ragged/VBD as/IN a/DT cloud/NN of/IN sunset/NN"