#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(\d{1,2}\/\d{1,2}\/\d{4})\n|((?:(?!\n*\d{1,2}\/\d{1,2}\/\d{4})[\s\S])+)"
Local $sString = "1/12/2011" & @CRLF & _
"I did something." & @CRLF & _
"" & @CRLF & _
"10/5/2013" & @CRLF & _
"I did something else." & @CRLF & _
"" & @CRLF & _
"Here is another line." & @CRLF & _
"" & @CRLF & _
"And another." & @CRLF & _
"" & @CRLF & _
"5/17/2014" & @CRLF & _
"Lalala." & @CRLF & _
"More text on another line."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")