import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2}\\/\\d{1,2}\\/\\d{4})\\n|((?:(?!\\n*\\d{1,2}\\/\\d{1,2}\\/\\d{4})[\\s\\S])+)";
final String string = "1/12/2011\n"
+ "I did something.\n\n"
+ "10/5/2013\n"
+ "I did something else.\n\n"
+ "Here is another line.\n\n"
+ "And another.\n\n"
+ "5/17/2014\n"
+ "Lalala.\n"
+ "More text on another line.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}