package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9]|1\d|2[0-5])$`)
var str = `12
1
0
25
24
26
123213
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}