$re = '/^(?:[1-9]|1\d|2[0-5])$/m';
$str = '12
1
0
25
24
26
123213
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);