using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\b\d{1,2}\b(\s*\,?\s*\b\d{1,2}\b)*\s*$";
string input = @"11111111
1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
1,11,14,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}