import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:\\d{1,2}|100)$)[0-9]\\d+$";
final String string = "1\n"
+ "12\n"
+ "100\n"
+ "101\n"
+ "102\n"
+ "102012\n"
+ "90\n"
+ "200\n"
+ "1000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}