$re = '/^(?!(?:\d{1,2}|100)$)[0-9]\d+$/m';
$str = '1
12
100
101
102
102012
90
200
1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);