#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'num_externe'\w+?)\t.*?\t.*?\t(?'ins_libl'\w+?)\t.*?\t.*?\t.*?\t(?'tsy_lib'\w+)\t(?'num_equipement'.+?)\t(?'commentaire_externe'.*?)\t(?'apt_localisation'.*?)\t.*?\t(?'apt_telephone'.*?)\t(?'apt_nom'.*?)\t"
Local $sString = "472777 LECLERCQ 51402007 51402 77 7 03 BD BROSSOLETTE 02000 LAON PLO CHC En panne/ TRES URGENT : pas de chauffage : 16? dans le logement BROSSOLETT/ 77 7 BROSSOLETT/ 7 03/ VIROULAUD/ 0323234164 VIROULAUD Guy N?:500886 PT890/VIROULAUD/ BROSSOLETT 77 7 BD BROSSOLETTE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")