import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'num_externe'\\w+?)\\t.*?\\t.*?\\t(?'ins_libl'\\w+?)\\t.*?\\t.*?\\t.*?\\t(?'tsy_lib'\\w+)\\t(?'num_equipement'.+?)\\t(?'commentaire_externe'.*?)\\t(?'apt_localisation'.*?)\\t.*?\\t(?'apt_telephone'.*?)\\t(?'apt_nom'.*?)\\t";
final String string = "472777 LECLERCQ 51402007 51402 77 7 03 BD BROSSOLETTE 02000 LAON PLO CHC En panne/ TRES URGENT : pas de chauffage : 16? dans le logement BROSSOLETT/ 77 7 BROSSOLETT/ 7 03/ VIROULAUD/ 0323234164 VIROULAUD Guy N?:500886 PT890/VIROULAUD/ BROSSOLETT 77 7 BD BROSSOLETTE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}