#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\[([^\[\]]*)\]\]"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed aliquet imperdiet sapien, [[xx]] vitae luctus augue convallis quis. Pellentesque felis eros, dignissim vitae [[ccvf]] dignissim sed, porta a leo. Duis tincidunt, ex sit amet sollicitudin vehicula, nibh velit ultrices ipsum, at feugiat enim arcu et [[dfg]] enim."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")