import Foundation
let pattern = #"\[\[([^\[\]]*)\]\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed aliquet imperdiet sapien, [[xx]] vitae luctus augue convallis quis. Pellentesque felis eros, dignissim vitae [[ccvf]] dignissim sed, porta a leo. Duis tincidunt, ex sit amet sollicitudin vehicula, nibh velit ultrices ipsum, at feugiat enim arcu et [[dfg]] enim."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)