$re = '/^\w+([!$%&\'()*+\.-]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/';
$str = 'chandandsad(07@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);