re = /^\w+([!$%&'()*+\.-]\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/
str = 'chandandsad(07@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end