$re = '/(^|\s)(?!\w*aa\w*)(\w+)/i';
$str = 'baa cec haw heef baas bat jackaay bar ha aa lar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);