re = /(^|\s)(?!\w*aa\w*)(\w+)/i
str = 'baa cec haw heef baas bat jackaay bar ha aa lar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end