$re = '/#\(tab\)(.*)#\(tab\)/m';
$str = '#(tab)stuff.imlookingfor#(tab)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);