import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\n]*\\n){4}([\\s\\S]*)";
final String string = "Однажды, в студёную зимнюю пору\n"
+ "Я из лесу вышел; был сильный мороз.\n"
+ "Гляжу, поднимается медленно в гору\n"
+ "Лошадка, везущая хворосту воз.\n"
+ "И, шествуя важно, в спокойствии чинном,\n"
+ "Лошадку ведёт под уздцы мужичок\n"
+ "В больших сапогах, в полушубке овчинном,\n"
+ "В больших рукавицах... а сам с ноготок!\n"
+ "«Здорово, парнище!» — «Ступай себе мимо!» —\n"
+ "«Уж больно ты грозен, как я погляжу!\n"
+ "Откуда дровишки?» — «Из лесу, вестимо,\n"
+ "Отец, слышишь, рубит, а я отвожу».\n"
+ "(В лесу раздавался топор дровосека.) —\n"
+ "«А что, у отца-то большая семья?» —\n"
+ "«Семья-то большая, да два человека\n"
+ "Всего мужиков-то: отец мой да я...» —";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}