# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[^\n]*\n){4}([\s\S]*)"
test_str = ("Однажды, в студёную зимнюю пору\n"
"Я из лесу вышел; был сильный мороз.\n"
"Гляжу, поднимается медленно в гору\n"
"Лошадка, везущая хворосту воз.\n"
"И, шествуя важно, в спокойствии чинном,\n"
"Лошадку ведёт под уздцы мужичок\n"
"В больших сапогах, в полушубке овчинном,\n"
"В больших рукавицах... а сам с ноготок!\n"
"«Здорово, парнище!» — «Ступай себе мимо!» —\n"
"«Уж больно ты грозен, как я погляжу!\n"
"Откуда дровишки?» — «Из лесу, вестимо,\n"
"Отец, слышишь, рубит, а я отвожу».\n"
"(В лесу раздавался топор дровосека.) —\n"
"«А что, у отца-то большая семья?» —\n"
"«Семья-то большая, да два человека\n"
"Всего мужиков-то: отец мой да я...» —")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.