import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s|[^a-zA-Z0-9.\\+_\\/\"\\>\\-]|^)(?:([a-zA-Z0-9\\+_\\-]+(?:\\.[a-zA-Z0-9\\+_\\-]+)*@)?(http:\\/\\/|https:\\/\\/|ftp:\\/\\/)?((?:(?:[a-z0-9][a-z0-9_%\\-_+]*\\.)+))((?:com|ca|co|edu|gov|net|org|dev|biz|cat|int|pro|tel|mil|aero|asia|coop|info|jobs|mobi|museum|name|post|travel|local|[a-z]{2}))((?::\\d{1,5}))?((?:[\\/|\\?](?:[\\-a-zA-Z0-9_%#*&+=~!?,;:.\\/]*)*)[\\-\\/a-zA-Z0-9_%#*&+=~]|\\/?)?)([^a-zA-Z0-9\\+_\\/\"\\<\\-]|$)";
final String string = "http://website.com/test.php?cid=cDSAF0gg2eETJg0hsagSA_325h280g\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}