const regex = /(\s|[^a-zA-Z0-9.\+_\/"\>\-]|^)(?:([a-zA-Z0-9\+_\-]+(?:\.[a-zA-Z0-9\+_\-]+)*@)?(http:\/\/|https:\/\/|ftp:\/\/)?((?:(?:[a-z0-9][a-z0-9_%\-_+]*\.)+))((?:com|ca|co|edu|gov|net|org|dev|biz|cat|int|pro|tel|mil|aero|asia|coop|info|jobs|mobi|museum|name|post|travel|local|[a-z]{2}))((?::\d{1,5}))?((?:[\/|\?](?:[\-a-zA-Z0-9_%#*&+=~!?,;:.\/]*)*)[\-\/a-zA-Z0-9_%#*&+=~]|\/?)?)([^a-zA-Z0-9\+_\/"\<\-]|$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s|[^a-zA-Z0-9.\\+_\\\/"\\>\\-]|^)(?:([a-zA-Z0-9\\+_\\-]+(?:\\.[a-zA-Z0-9\\+_\\-]+)*@)?(http:\\\/\\\/|https:\\\/\\\/|ftp:\\\/\\\/)?((?:(?:[a-z0-9][a-z0-9_%\\-_+]*\\.)+))((?:com|ca|co|edu|gov|net|org|dev|biz|cat|int|pro|tel|mil|aero|asia|coop|info|jobs|mobi|museum|name|post|travel|local|[a-z]{2}))((?::\\d{1,5}))?((?:[\\\/|\\?](?:[\\-a-zA-Z0-9_%#*&+=~!?,;:.\\\/]*)*)[\\-\\\/a-zA-Z0-9_%#*&+=~]|\\\/?)?)([^a-zA-Z0-9\\+_\\\/"\\<\\-]|$)', 'gi')
const str = `http://website.com/test.php?cid=cDSAF0gg2eETJg0hsagSA_325h280g"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}