#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<=(>))([\S\s]*)(?=(<\/))"
Local $sString = "<script type="text/javascript">" & @CRLF & _
"" & @CRLF & _
" inner_text_1" & @CRLF & _
" <c:set var="" value="">inner_text_2</c:set>" & @CRLF & _
"" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")