using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(>))([\S\s]*)(?=(<\/))";
string input = @"<script type=""text/javascript"">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}