using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"}}\s+({{If [\s\S]*?{{EndIf}})";
string input = @"{{If ""{{Line}}"" != ""}}
{{If ""{{Line}}"" != ""}}
<li id=""{{Required:Id}}"" class=""menuEntry line"">
{{EndIf}}
<li id=""{{Required:Id}}"" class=""menuEntry line"">
{{EndIf}}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}