package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$[0-9A-Fa-f]{2}(?:,\$[0-9A-Fa-f]{2})+)`)
var str = `BYTE $66,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$13,$14,$01,$19,$20,$01,$20,$17,$08,$09,$0C,$05,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$66 // comment
BYTE $66,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$20,$66`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}