const regex = new RegExp('(\\$[0-9A-Fa-f]{2}(?:,\\$[0-9A-Fa-f]{2})+)', 'g')
const str = `BYTE \$66,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$13,\$14,\$01,\$19,\$20,\$01,\$20,\$17,\$08,\$09,\$0C,\$05,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$66 // comment
BYTE \$66,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$20,\$66`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}