#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\$)#.*$(*SKIP)(*F)|\brm\b"
Local $sString = " "$#" #rm" & @CRLF & _
"# rm" & @CRLF & _
"rm # rm" & @CRLF & _
" rm" & @CRLF & _
""rm "" & @CRLF & _
"'rm '" & @CRLF & _
"`rm `" & @CRLF & _
"{rm }" & @CRLF & _
"$# rm # rm" & @CRLF & _
"rm rm # rm" & @CRLF & _
"rm # rm rm" & @CRLF & _
"rmremovermlink"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")