import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#[\\*c@]\\K[\\S].*$";
final String string = "#*OQL[C++]: Extending C++ with an Object Query Capability\n\n"
+ "#@José A. Blakeley\n\n"
+ "#t1995\n\n"
+ "#cModern Database Systems\n\n"
+ "#index0\n\n"
+ "#*Transaction Management in Multidatabase Systems\n\n"
+ "#@Yuri Breitbart,Hector Garcia-Molina,Abraham Silberschatz\n\n"
+ "#t1995\n\n"
+ "#cModern Database Systems\n\n"
+ "#index1\n\n"
+ "#@ \n"
+ "#@José A. Blakeley ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}