$re = '/#[\*c@]\K[\S].*$/m';
$str = '#*OQL[C++]: Extending C++ with an Object Query Capability
#@José A. Blakeley
#t1995
#cModern Database Systems
#index0
#*Transaction Management in Multidatabase Systems
#@Yuri Breitbart,Hector Garcia-Molina,Abraham Silberschatz
#t1995
#cModern Database Systems
#index1
#@
#@José A. Blakeley ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);