$re = '/^[^^,]+?(?<!\')\'?\^\'?(?!\')[^^,]+?$/m';
$str = '\'asdf1524-sdfaA\'^\'sdfa322=\'
\'sdfa22_\'^$myvar
$myvar^\'asAf34%\'
[\'+\',\'*\',\'^\',\'%\']
\'^\'=>2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);