re = /^[^^,]+?(?<!')'?\^'?(?!')[^^,]+?$/m
str = '\'asdf1524-sdfaA\'^\'sdfa322=\'
\'sdfa22_\'^$myvar
$myvar^\'asAf34%\'
[\'+\',\'*\',\'^\',\'%\']
\'^\'=>2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end