use strict;
my $str = 'CREATE TABLE asd (
_id INTEGER PRIMARY KEY AUTOINCREMENT,
name TEXT NOT NULL,
breed TEXT NOT NULL,
gender INTEGET NOT NULL DEFAULT 0,
weight INTEGER NOT NULL DEFAULT 0
);
CREATE TABLE asd (
_id INTEGER PRIMARY KEY AUTOINCREMENT,
name TEXT NOT NULL,
breed TEXT NOT NULL,
gender INTEGER NOT NULL DEFAULT 0,
weight INTEGER NOT NULL DEFAULT 0
);';
my $regex = qr/(?:CREATE TABLE.+[a-z]\s?\()(?:\n?\t?(?:[a-z_]+\s(?:INTEGER|TEXT|BLOB|REAL|NULL).*|\);$))+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}