$re = '/(?:CREATE TABLE.+[a-z]\s?\()(?:\n?\t?(?:[a-z_]+\s(?:INTEGER|TEXT|BLOB|REAL|NULL).*|\);$))+/';
$str = 'CREATE TABLE asd (
_id INTEGER PRIMARY KEY AUTOINCREMENT,
name TEXT NOT NULL,
breed TEXT NOT NULL,
gender INTEGET NOT NULL DEFAULT 0,
weight INTEGER NOT NULL DEFAULT 0
);
CREATE TABLE asd (
_id INTEGER PRIMARY KEY AUTOINCREMENT,
name TEXT NOT NULL,
breed TEXT NOT NULL,
gender INTEGER NOT NULL DEFAULT 0,
weight INTEGER NOT NULL DEFAULT 0
);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);