package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d[0-9]{7}[-]{1}\d[0-9]{0}$`)
var str = `01203977-2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}