$re = '/^\d[0-9]{7}[-]{1}\d[0-9]{0}$/';
$str = '01203977-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);