$re = '/\[.*?\]/m';
$str = 'test me [caption id="attachment_4487" align="alignright" width="600"]test me';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);