re = /\[.*?\]/m
str = 'test me [caption id="attachment_4487" align="alignright" width="600"]test me'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end