#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)(FACTURA.*?(?!ELECTR))"
Local $sString = "CLINICA LAS UBNDES S.A. R.U.T.: 93.930.000-7" & @CRLF & _
"HOSPÍ ES IONAMIENTO" & @CRLF & _
"CASA TAL: e e - LAS CONDES - SANTIAGO FACTURA NO AFECTA O" & @CRLF & _
"SP” CLÍNICA SUCURSALES: LO FONTECILLA 4174 - LAS CONDES EXENTA ELECTRONICA" & @CRLF & _
"CHICUREO S/N - COLINA N* 211918" & @CRLF & _
"E LAS CONDES EMILLE ALLAIS £91 - LO BARNECHEA" & @CRLF & _
"CAMINO A VALLE NEVADO 41333 - LO BARNECHEA" & @CRLF & _
"LOS PRESIDENTES $8950 - PEÑALOLEN" & @CRLF & _
"S.l.1. - SANTIAGO ORIENTE" & @CRLF & _
"www.clc.cl" & @CRLF & _
"Fecha Emisión : 08-02-2023 RUT : 10.143.057-K" & @CRLF & _
"Señor(es) : NALLY FERNANDEZ MARIA SOLEDAD" & @CRLF & _
"Dirección : MARTIN DE ZAMORA 6306 Vencimiento" & @CRLF & _
"Ciudad : SANTIAGO Comuna : LAS CONDES" & @CRLF & _
"Giro : ACTIVIDADES NO ESPECIFICADAS Forma de Pago _ : CONTADO" & @CRLF & _
"1.698.196" & @CRLF & _
"DESCRIPCIÓN" & @CRLF & _
"PETCT" & @CRLF & _
"1.698.196" & @CRLF & _
"102001" & @CRLF & _
"cuy SÉ Y" & @CRLF & _
"3 |" & @CRLF & _
"Ss $" & @CRLF & _
"Y OCHO MIL CIE" & @CRLF & _
"SON: UN MILLÓN SEISCIENTOS NOVENTA AEB NENENTA" & @CRLF & _
"SEIS PESOS" & @CRLF & _
"MONTO DSCTO [5 o" & @CRLF & _
"MONTO EXENTO |$ 1.698.196" & @CRLF & _
"1.698.196" & @CRLF & _
"01: j d j sio" & @CRLF & _
"y i We" & @CRLF & _
"Timbre Electronico Sil fique Documento: ww" & @CRLF & _
"Res. 138 de 29-11-2011 Veri" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")