using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(FACTURA.*?(?!ELECTR))";
string input = @"CLINICA LAS UBNDES S.A. R.U.T.: 93.930.000-7
HOSPÍ ES IONAMIENTO
CASA TAL: e e - LAS CONDES - SANTIAGO FACTURA NO AFECTA O
SP” CLÍNICA SUCURSALES: LO FONTECILLA 4174 - LAS CONDES EXENTA ELECTRONICA
CHICUREO S/N - COLINA N* 211918
E LAS CONDES EMILLE ALLAIS £91 - LO BARNECHEA
CAMINO A VALLE NEVADO 41333 - LO BARNECHEA
LOS PRESIDENTES $8950 - PEÑALOLEN
S.l.1. - SANTIAGO ORIENTE
www.clc.cl
Fecha Emisión : 08-02-2023 RUT : 10.143.057-K
Señor(es) : NALLY FERNANDEZ MARIA SOLEDAD
Dirección : MARTIN DE ZAMORA 6306 Vencimiento
Ciudad : SANTIAGO Comuna : LAS CONDES
Giro : ACTIVIDADES NO ESPECIFICADAS Forma de Pago _ : CONTADO
1.698.196
DESCRIPCIÓN
PETCT
1.698.196
102001
cuy SÉ Y
3 |
Ss $
Y OCHO MIL CIE
SON: UN MILLÓN SEISCIENTOS NOVENTA AEB NENENTA
SEIS PESOS
MONTO DSCTO [5 o
MONTO EXENTO |$ 1.698.196
1.698.196
01: j d j sio
y i We
Timbre Electronico Sil fique Documento: ww
Res. 138 de 29-11-2011 Veri
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}