using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s+u*c+k+";
string input = @"You should eat suck, sck, and suuucky every day.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}