$re = '/s+u*c+k+/';
$str = 'You should eat suck, sck, and suuucky every day.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);