package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-]?\d+(?:\.\d+(?:E[+-]\d+)?)?(\s|$))`)
var str = `4 F= -0.15857709E+03 E0= -0.15857306E+03 d E =-0.612557E+01 mag= 111.0022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}