// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([-]?\d+(?:\.\d+(?:E[+-]\d+)?)?(\s|$))").unwrap();
let string = "4 F= -0.15857709E+03 E0= -0.15857306E+03 d E =-0.612557E+01 mag= 111.0022";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}