const regex = /(\b[A-Z]\w+\b\s??){3,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b[A-Z]\\w+\\b\\s??){3,}', '')
const str = `Gaius Julius Caesar `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}