$re = '/(\b[A-Z]\w+\b\s??){3,}/';
$str = 'Gaius Julius Caesar ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);