const regex = /^\d{4}-([0]\d|1[0-2])-([0-2]\d|3[01])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}-([0]\\d|1[0-2])-([0-2]\\d|3[01])$', '')
const str = `1845-10-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}