import Foundation
let pattern = #"^\d{4}-([0]\d|1[0-2])-([0-2]\d|3[01])$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1845-10-"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}