package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)value(.*?)value`)
var str = `text value more text value other text
text value more text value other text`
var substitution = "${1}10${2}20"
fmt.Println(re.ReplaceAllString(str, substitution))
}