$re = '/(.*?)value(.*?)value/m';
$str = 'text value more text value other text
text value more text value other text';
$subst = "${1}10${2}20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;